通达信主力异动买入指标公式(附源码破译和源码)

永华证券_配资炒股网站_股票配资手机操作

你的位置:永华证券_配资炒股网站_股票配资手机操作 > 永华证券 > 通达信主力异动买入指标公式(附源码破译和源码)
通达信主力异动买入指标公式(附源码破译和源码)
发布日期:2024-02-28 12:42    点击次数:179

编程思路破译

SR1赋值:10日前的最高价=2*10+1日内最高价的最高值

SR2赋值:SR1的10日过滤

SR3赋值:若SR2则将最近10+1周期置为1

HDD赋值:SR3的10日过滤

前高高赋值:上次HDD距今天数日前的最高价

倍量量赋值:成交量(手)/1日前的成交量(手)>=1.9

突破前高高赋值:收盘价上穿前高高

强庄赋值:倍量量 AND 突破前高高

填充背景

K线

BK赋值:如果属于某板块,返回0.2,否则返回如果属于某板块,返回0.2,否则返回如果属于某板块,返回0.05,否则返回0.1

ZTBTJ1赋值:收盘价>=(1日前的收盘价*1.1*100的整数部分/100)和计算涨停价的较大值

ZTBTJ2赋值:收盘价>=(1日前的收盘价*1.05*100的整数部分/100)

涨停提示赋值:如果模糊匹配品种名称ORNAMELIKE('*')ORNAMELIKE('SS')ORNAMELIKE('S'),返回ZTBTJ2,否则返回ZTBTJ1

当满足条件如果模糊匹配品种代码ORCODELIKE('399')ORCODELIKE('880')ORNAMELIKE('超大盘'),返回无效数,否则返回涨停提示ANDPERIOD=5ANDO不等于最高价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色

MID赋值:(3*收盘价+最低价+开盘价+最高价)/6

输出主力:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210,画红色

如果主力>=1日前的主力,返回主力,否则返回无效数,画红色

如果主力<=1日前的主力,返回主力,否则返回无效数,画绿色

如果主力<=1日前的主力,返回主力,否则返回无效数,画绿色

HAN赋值:日期=日期

A赋值:9日前的最高价=2*9+1日内最高价的最高值

B赋值:A的9日过滤

AB赋值:若B则将最近9+1周期置为1

HD赋值:AB的9日过滤

前高赋值:上次HD距今天数日前的最高价

倍量赋值:成交量(手)/1日前的成交量(手)>=1.1

突破前高赋值:收盘价上穿前高

XG赋值:倍量AND突破前高

YX赋值:当满足条件XG时,在最低价位置画直线起点,当满足条件XG时,在最低价位置画直线终点,1表示是否延长.

重点赋值:XG AND 强庄

当满足条件重点时,在8和88位置之间画柱状线,宽度为99999.88,0不为0则画空心柱.*HAN,COLOR000000

当满足条件重点时,在8和88位置之间画柱状线,宽度为0.01.88,0不为0则画空心柱.*HAN,COLOR505050

当满足条件重点时,在70位置书写文字*HAN,画红色

当满足条件重点时,在60位置书写文字*HAN,画红色

当满足条件重点时,在50位置书写文字*HAN,画红色

当满足条件重点时,在40位置书写文字*HAN,画红色

当满足条件重点时,在30位置书写文字*HAN,画红色

当满足条件重点时,在10位置书写文字*HAN,画红色

当满足条件1时,在横轴0.00纵轴0.15位置书写文字,画黄色

程序源码

SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);

SR2:=FILTER(SR1,10);

SR3:=BACKSET(SR2,10+1);

HDD:=FILTER(SR3,10);

前高高:=REF(H,BARSLAST(HDD));

倍量量:=VOL/REF(VOL,1)>=1.9;

突破前高高:=CROSS(C,前高高);

强庄:=倍量量 AND 突破前高高;

DRAWGBK(C>1,RGB(0,0,0),RGB(1,1,1),1,0,0);

DRAWKLINE(H,O,L,C);

BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2 ,IF(INBLOCK('ST板块'),0.05,0.1)));

ZTBTJ1:=C>=MAX((INTPART(REF(C,1)*1.1*100)/100),ZTPRICE(REF(C,1),BK));

ZTBTJ2:=C>=(INTPART(REF(C,1)*1.05*100)/100);

涨停提示:=IF(NAMELIKE('ST') OR NAMELIKE('*') OR NAMELIKE('SS') OR NAMELIKE('S'),ZTBTJ2,ZTBTJ1);

STICKLINE(IF(CODELIKE('999') OR CODELIKE('399') OR CODELIKE('880') OR NAMELIKE('超大盘'),DRAWNULL,涨停提示 AND PERIOD=5 AND O!=H),C,O,3,0),COLORYELLOW;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

主力:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

IF(主力>=REF(主力,1),主力,DRAWNULL),COLORRED;

IF(主力<=REF(主力,1),主力,DRAWNULL),COLORGREEN;

IF(主力<=REF(主力,1),主力,DRAWNULL),COLORGREEN;

HAN:=DATE=DATE;

A:=REF(HIGH,9)=HHV(HIGH,2*9+1);

B:=FILTER(A,9);

AB:=BACKSET(B,9+1);

HD:=FILTER(AB,9);

前高:=REF(H,BARSLAST(HD));

倍量:=VOL/REF(VOL,1)>=1.1;

突破前高:=CROSS(C,前高);

XG:=倍量AND突破前高;

YX:=DRAWLINE(XG,L,XG,L,1);

重点:=XG AND 强庄;

STICKLINE(重点,8,88,99999.88,0)*HAN,COLOR000000;

STICKLINE(重点,8,88,0.01.88,0)*HAN,COLOR505050;

DRAWTEXT(重点,70,' ▲')*HAN,COLORRED;

DRAWTEXT(重点,60,' 〓')*HAN,COLORRED;

DRAWTEXT(重点,50,' 红')*HAN,COLORRED;

DRAWTEXT(重点,40,' 箭')*HAN,COLORRED;

DRAWTEXT(重点,30,' 头')*HAN,COLORRED;

DRAWTEXT(重点,10,'◢〓◣')*HAN,COLORRED;

DRAWTEXT_FIX(1,0.00,0.15,0,' 异动'),COLORYELLOW;

该公式包含未来函数:BACKSET未发现:WINNER...未发现:LWINNER...未发现:PWINNER...未发现:COST...未发现:CAPITAL...未发现:DYNAINFO...未发现:FINANCE...未发现:XMA...未发现:#MONTH...未发现:#WEEK...未发现:#YEAR...未发现:DHIGH...未发现:DOPEN...未发现:DLOW...未发现:DCLOSE...未发现:DVOL...未发现:BARSNEXT...未发现:REFX...未发现:REFXV...该公式包含未来函数:DRAWLINE

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

  • 上一篇:没有了

  • 下一篇:A股医疗公司迎2024年首起收购案
  • Powered by 永华证券_配资炒股网站_股票配资手机操作 @2013-2022 RSS地图 HTML地图

    Copyright 365建站 © 2013-2021 365建站器 版权所有